Chatrace - Instagram outage – Incident details

All systems operational

Instagram outage

Resolved
Major outage
Started about 3 years agoLasted 1 day

Affected

Instagram

Major outage from 1:23 PM to 12:05 AM

Updates
  • Resolved
    Resolved

    Facebook just resolved the issue!

  • Investigating
    Investigating

    Facebook is current investigate the issue.